IonCube Loader is a tool, that is needed to run files which are encoded with ionCube PHP Encoder. The aforementioned is an app employed to make PHP code human unreadable, as a way to protect it from reverse engineering and / or illegal usage. Various script-driven apps, particularly community forums, content management systems and e-commerce solutions are encrypted with ionCube PHP Encoder, therefore if you acquire a script and you find that ionCube is one of the hosting environment prerequisites, you need to ensure that your web hosting server has the instrument pre-installed. While it is not that hard to install it if you have your own server, it is almost impossible to do that on a shared web hosting server because the PHP environment shall have to be precompiled and all the clients on the server shall be affected.

IonCube in Cloud Website Hosting

IonCube Loader is provided with all cloud website hosting packages that we provide, so if you need it to install and run a script app that needs it, you can enable it with a click in the Advanced section of the Hepsia Control Panel. Due to the fact that you are able to change the PHP release that's active for your account in the same section, you need to enable the tool for each new version that you set. When you're more skillful, you will be able to employ a php.ini file in a domain or subdomain folder and set both the PHP version as well as the status of ionCube Loader for this particular website only, without affecting the entire account. In this way you will be able to manage both new and older script apps for multiple sites within the same account - something that you can't do with various other web hosting service providers available on the market.

IonCube in Semi-dedicated Hosting

Due to the fact that all the semi-dedicated server accounts are set up on our advanced cluster platform and ionCube Loader is available on it, you shall be able to use any script application that needs the tool so as to function effectively. With several clicks in your Hepsia website hosting Control Panel you are able to activate or deactivate ionCube for the PHP version that is currently active for your account. Because we support a couple of releases of PHP simultaneously, you'll have to do that each time you switch to a new release, but if you revert back to a release that you have already used, our system will remember your choice and ionCube Loader will already be activated. If you have several websites in the same account and they require different releases of PHP, you can set up a php.ini file in every single domain folder and with a couple of lines of program code you will be able to define both the PHP version and the status of ionCube regardless of what is selected for the hosting account as a whole.